Skip to content

chore(monorepo): update overrides axios to >=1.20.0 [security] - #27

Open
renovate[bot] wants to merge 1 commit into
mainfrom
renovate/npm-axios-vulnerability
Open

renovate[bot] wants to merge 1 commit into
mainfrom
renovate/npm-axios-vulnerability

chore(monorepo): update overrides axios to >=1.20.0 [security]

80c1cbb
Select commit
Loading
Failed to load commit list.
Socket Security / Socket Security: Pull Request Alerts succeeded Oct 24, 2026 in 36s

Pull Request #27 Alerts: Complete with warnings

Report Status Message
PR #27 Alerts ⚠️ Found 2 project alerts

Pull request alerts notify when new issues are detected between the diff of the pull request and it's target branch.

Details

Warning

Review the following alerts detected in dependencies.

According to your organization's Security Policy, it is recommended to resolve "Warn" alerts. Learn more about Socket for GitHub.

Priority Alert  (click "▶" to expand/collapse) Action
Critical priority
Critical CVE: simple-git: VISUAL editor environment variable is omitted from unsafe editor detection in npm `@simple-git/argv-parser`

CVE: GHSA-v5rq-49vh-5v5c simple-git: VISUAL editor environment variable is omitted from unsafe editor detection (CRITICAL)

Affected versions: < 2.0.1

Patched version: 2.0.1

From: pnpm-lock.yaml → npm/@storm-software/git-tools@2.132.11 → npm/@simple-git/argv-parser@1.1.1

ℹ Read more on: This package | This alert | What is a critical CVE?

Next steps: Take a moment to review the security alert above. Review the linked package source code to understand the potential risk. Ensure the package is not malicious before proceeding. If you're unsure how to proceed, reach out to your security team or ask the Socket team for help at support@socket.dev.

Suggestion: Remove or replace dependencies that include known critical CVEs. Consumers can use dependency overrides or npm audit fix --force to remove vulnerable dependencies.

Mark the package as acceptable risk. To ignore this alert only in this pull request, reply with the comment @SocketSecurity ignore npm/@simple-git/argv-parser@1.1.1. You can also ignore all packages with @SocketSecurity ignore-all. To ignore an alert for all future pull requests, use Socket's Dashboard to change the triage state of this alert.

Warn
Medium priority
Critical CVE: npm simple-git unsafe-operation guard does not block trailer command configuration

CVE: GHSA-x6jw-m9v5-85vh simple-git unsafe-operation guard does not block trailer command configuration (CRITICAL)

Affected versions: >= 3.15.0 < 4.0.1

Patched version: 4.0.1

From: pnpm-lock.yaml → npm/@storm-software/git-tools@2.132.11 → npm/simple-git@3.36.0

ℹ Read more on: This package | This alert | What is a critical CVE?

Next steps: Take a moment to review the security alert above. Review the linked package source code to understand the potential risk. Ensure the package is not malicious before proceeding. If you're unsure how to proceed, reach out to your security team or ask the Socket team for help at support@socket.dev.

Suggestion: Remove or replace dependencies that include known critical CVEs. Consumers can use dependency overrides or npm audit fix --force to remove vulnerable dependencies.

Mark the package as acceptable risk. To ignore this alert only in this pull request, reply with the comment @SocketSecurity ignore npm/simple-git@3.36.0. You can also ignore all packages with @SocketSecurity ignore-all. To ignore an alert for all future pull requests, use Socket's Dashboard to change the triage state of this alert.

Warn

View full report